Fileinfo
PHP Manual

安装/配置

Table of Contents

User Contributed Notes

RickertB 17-Feb-2009 11:14
When installing fileinfo on php5.2 on ubuntu and having a problem with phpize,

you must also install the php5-dev package..
apt-get install php5-dev

Then verify if 'phpize' is in your PATH
Anonymous 10-Oct-2008 06:05
for gentoo you will need to emerge pecl-fileinfo
grillen at abendstille dot at 09-Oct-2008 10:54
on opensuse 10.2 systems you'll need the file-devel package.
greg at freephile dot com 01-Oct-2008 05:29
For Kubuntu systems and probably most other Linuxes, after installing libmime-devel, I could successfully install the PECL Fileinfo package.

$ sudo apt-get install libmagic-dev

$ sudo pecl install Fileinfo

Fileinfo
PHP Manual